邮件服务器-邮件系统-邮件技术论坛(BBS)

 找回密码
 会员注册
查看: 4404|回复: 3
打印 上一主题 下一主题

[经验] Exchange 2007 的数据库还原

[复制链接]
跳转到指定楼层
顶楼
发表于 2008-11-5 09:09:18 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式

Exchange 2007 的数据库还原

环境:服务器A 活动目录和Exchange 2007
      服务器B 活动目录和Exchange 2007 (服务器A和服务器B 的硬件配置完全相同)
      注:虽然大多数公司由于现实条件限制常常将Exchange2007及活动目录装于同一台服务器但是出于微软及个人强烈建议不要将活动目录与Exchange 2007装于同一台服务器 。

一 利用Ntbackup备份 服务器A System state数据库 及Microsoft Exchange Server 下的所有存储组数据库(如只需还原单一存储组数据,也可以做单独备份)。


二
记录下服务器A 中Exchange 2007 的安装路径及计算机的FQDN。(这一步相当重要,如果被还原的服务器与备份服务器的Exchange 2007 安装目录不同可能导致还原后Exchange 2007 相关服务无法启动。)
三
启动服务器B 按F8进入目录还原模式

四
进入系统后再次启用Ntbackup工具将system state数据库还原。




五
重启服务器B 进入正常模式(进入系统过程中出现错误此为正常现象)


开始—运行—services.msc打开服务管理器查看所有Exchange 2007 相关服务是否自动启动如没有请手动启动。如不能手动启动请查看是否如第二步骤所说您的Exchange 2007的安装目录与之前备份服务器的安装目录不同。

六 1启动Ntbackup工具还原Exchange 2007 存储组数据库(此过程可能要花费大量时间我们公司四百多人的数据库大概五十分钟的时间)


2如打开
Exchange
管理控制台
安装数据库发现如图所示你需要修复数据库

3利用Eseutil /mh 查看存储组数据库是否处于Dirty shutdown 状态,如果“是”请修复数据库

4利用 Eseutil /p修复存储组数据库(此过程可能需要大量时间)


修复完成如磁盘空间不足利用Eseutil –d 进行数据库碎片整理(此过程需要大量时间)

5最后装入数据库

七
利用owa测试成功!哦耶!大功告成!!!


后注:分享一下我恢复中的错误:


1
安装目录不同:由于第一次做恢复经验不足呵呵将备份服务器B 的硬盘分为C、D、E 三个区将Exchange 2007 安装于E盘而还原服务器A却安装于D盘最后导致还原后所有Exchange相关服务都无法启动后来将服务器的E盘分区号改为D 以为可以挽回但是只启动了部分服务pop3 IMAP4及传输服务始终无法启动而且 owa 访问出现错误页面。无奈重新安装系统。

2
硬件不相同:备份服务器A与还原服务器B同为IBM的3650 但是内存不同一个10G另一个却为6G导致还原的时候system state 中的驱动文件不匹配还原失败!后来不得不找了一台相同配置的服务器!


此过程经过了20多天,安装服务器系统、查看资料无数终于功夫不负有心人哈哈!!!


沙发
发表于 2008-11-5 10:56:28 | 只看该作者
LZ强,这灾难恢复连硬件也要完完全全相同啊。内存少四G也不行,牛了。如果两台机器内存大小一样,品牌不一样会不会也出现问题。。。
藤椅
发表于 2008-11-5 11:18:52 | 只看该作者
  多谢分享
板凳
 楼主| 发表于 2008-11-5 13:45:57 | 只看该作者
估计会出问题 备份system state 同时备份了原先服务器的硬件信息包括驱动文件什么的
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

小黑屋|手机版|Archiver|邮件技术资讯网

GMT+8, 2026-9-27 11:33

Powered by Discuz! X3.2

© 2001-2016 Comsenz Inc.

本论坛为非盈利中立机构,所有言论属发表者个人意见,不代表本论坛立场。内容所涉及版权和法律相关事宜请参考各自所有者的条款。
如认定侵犯了您权利,请联系我们。本论坛原创内容请联系后再行转载并务必保留我站信息。此声明修改不另行通知,保留最终解释权。
*本论坛会员专属QQ群:邮件技术资讯网会员QQ群
*本论坛会员备用QQ群:邮件技术资讯网备用群

快速回复 返回顶部 返回列表